Xorg failed to Start--No devices to configure

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Xorg failed to Start--No devices to configure

fxddyy
Hello Everyone!
In this post,I want to report a Bug in MidnightBSD (1.2 i386)

My CPU is Intel J1900 (integrated video card) with DDR3 4G

I want to install a Graphical Environment,and I try the Document saying to install Xorg using
"mport install Xorg"
Everything goes well.But when I tried to start X using "strax"(Version 7.7_2)
the screen become very WEIRD.
Half of the screen was filled with white and red patterns with different letters.
And when I tries to move mouse,the patterns moves as well.
BUT I can't EXIT IT!!!
screen
At first,I consider this is a software problem cause by inproper installation,
I tried to reinstall the software,but the problem continues.
Then I tried to run the auto configuation comment "Xorg -configurate"
And get a ERROR message that I cannot solve:

"[  1229.225] No devices to configure.  Configuration failed."

For more details,the Complete Xorg Log File was here:
Xorg.log

It seems it is because can't find and display device.
All I have to do is to change a machine and try again.
This time is Intel i7-370 with individual graphic card MSI R6670 2G and mother board H55M-E33
However it FAILED again too,with the same error message.

Therefore,I think it is a BIG Kerenal-Bug which need the developer to know.
I install Liunx Distribution like Debian on the same machine,everythiing is perfectly OK.
And before it jump to graphal desktop,the console window will auto resize to correct screen resolution
and MidnightBSD can't do that.
Is this cause the Xorg failed to start?

I hope somebody can give me a hand!
Thank you!